Throttle Quadrant

The place to ask for help or solve each others technical issues and discuss hardware

Throttle Quadrant

Postby Aviator 1 » Tue May 16, 2017 8:15 pm

Does anyone know I went onto to P3D to do a flight and found my throttle Quadrant was not working but the green light stays solid. I thought it maybe a broken wire or something but is not the case.
I plugged in my spare from my older yoke and works fine. I have checked the pins any ideas.
Aviator 1
Forum Addict
 
Topic author
Joined: Tue Mar 24, 2015 5:14 pm
Posts: 457

Re: Throttle Quadrant

Postby FunkymonkeyNZ » Thu May 18, 2017 8:13 am

Truth be told that these throttle quadrants dont really stand up to the test of time. i purchased a second quadrant (usb type) not long after purchasing my yoke. and it lasted all of a year and a half. i had the electrician at my workplace take a look at it, and same as yours, the light was on but it wasn't registering the throttles.
Sorry about the bad news bud :(
Chris Maher
Image
NZ CPL(A)+MEIR, NZNV,
User avatar
FunkymonkeyNZ
Forum Addict
 
Joined: Sat Sep 22, 2007 10:18 pm
Posts: 220
Location: Invercargill

Re: Throttle Quadrant

Postby Aviator 1 » Thu May 18, 2017 12:47 pm

FunkymonkeyNZ wrote:Truth be told that these throttle quadrants dont really stand up to the test of time. i purchased a second quadrant (usb type) not long after purchasing my yoke. and it lasted all of a year and a half. i had the electrician at my workplace take a look at it, and same as yours, the light was on but it wasn't registering the throttles.
Sorry about the bad news bud :(


Thanks for the reply, I have never had any problems with my Saitek gear before but your right they don't last. I am glad I have a spare now that Saitek is now gone and now waiting for the Logitech versions.
It would be great to go like the real thing all metal I would certainly be happy to pay more for it.
Aviator 1
Forum Addict
 
Topic author
Joined: Tue Mar 24, 2015 5:14 pm
Posts: 457

Re: Throttle Quadrant

Postby Splitpin » Sat May 20, 2017 10:32 am

Funky ... you will be pleased to know your old Saitek system is still going strong here in my cave .
User avatar
Splitpin
NZFF Pro
 
Joined: Mon Aug 03, 2009 12:15 pm
Posts: 15044
Location: Christchurch NZ


Return to Technical Issues

Who is online

Users browsing this forum: No registered users and 2 guests